Forum Index
Jeep Horizons HomeLinksJeep Horizons Tech Write-upsJeep newsLand useContact

 Watched TopicsWatched Topics   FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

HELP PLEASE!!! 1999 GCL Won't start, NO OBD2 coms


 
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum
View previous topic :: View next topic  
Author Message
SDale
Member


Joined: 13 Dec 2006

PostPosted: Fri Jun 04, 2010 7:41 pm    Post subject: HELP PLEASE!!! 1999 GCL Won't start, NO OBD2 coms Reply with quote

I searched and couldn't find an answer to my particular problem.

I have a 99 Grand Cherokee Laredo 4.0

I was on my way to pick up my daughter then my jeep lost power, stalled out and died. The Check Engine, Low Fuel & Check Gauges lights came on. When I turn the ignition to the on position, I get the same lights and the gauges go to the lowest positions. No fuel level, no temp... NADA.

I tried to start it a few times after checking fuses & relays. Crank but no start. It's got new fuel pump, crank position sensor and coil bar. All replaced in the last 4 months.

I tried hooking up 3 different scanners and they could NOT connect to the OBD2 system. They've always worked and connected in the past. So now I can't pull codes to see what happened.

I jumpered the fuel pump and it's good. Swapped out the new CPS for the old one (it was working at the time) and changed to another good coil bar. All same result. Crank, no start.

Do I have a dead ECM?!?!?!?!?
Back to top
View user's profile Send private message Send e-mail
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Sat Jun 05, 2010 6:01 am    Post subject: Reply with quote

You may have a burnt wire in the harness that goes to the ECM.
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
SDale
Member


Joined: 13 Dec 2006

PostPosted: Sat Jun 05, 2010 9:24 am    Post subject: FOUND IT! Reply with quote

Man... I've been working on this thing since 6:30 this morning.

I started stripping the loom off the harness that the CPS hooks into and found 2 wires that were chafed and shorting out on each other. I'm not sure how they were able to move enough to chafe through their insulation. But after stripping them back and repairing the short, my Jeep starts and runs fine! WOO HOO!!!
Back to top
View user's profile Send private message Send e-mail
Orangeamc13
Got Rev Limiter?
Got Rev Limiter?


Joined: 20 Feb 2006
Location: East Springfield, Massachusetts - U.S.A.

PostPosted: Sat Jun 05, 2010 6:27 pm    Post subject: Reply with quote

thumbs
_________________
Underground Jeeps
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger
SDale
Member


Joined: 13 Dec 2006

PostPosted: Sun Jun 06, 2010 5:35 pm    Post subject: Reply with quote

Thanks Orange! If it wasn't for you I wouldn't have started tracing through the harness! Very Happy
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Grand Cherokee Forum All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Visit links4jeeps.com for write-ups, forums and clubs




Jeep®, Wrangler, Cherokee, Liberty and Grand Cherokee are copyrighted and trademarked to Chrysler LLC.
jeephorizons.com is not in any way associated with or endorsed by the Chrysler LLC.
All other content is copyright Jeep Horizons 2004-2008.
Tech write-ups Links Discussion board Land use News Site Map Terms of Use

Powered by phpBB © 2001, 2005 phpBB Group